User Tools

Site Tools


java

This page in English

Java

Bakgrund

Java är programvara på datorn som i sin tur möjliggör körning av vissa andra programvaror. Java möjliggör körning av programvaror som i vissa fall kan användas direkt i en webbläsare, t.ex. i Internet Explorer. Bland annat många administrativa system kräver Java.

Frågor och svar

Vilken utgåva av Java installeras?

Den utgåva av Java som installeras som standard på våra datorer för administrativ personal är Java Runtime Environment (JRE). Det är en minimal utgåva som innehåller precis så mycket som behövs för de administrativa systemen.

På datorer i studentdatorsalar och i labbmiljö är det istället Java Development Kit (JDK) som installeras. Det är en betydligt större utgåva som dessutom innehåller det som behövs för utveckling och felsökning av programvaror i Java.

Har jag Java på min dator?

Vill du testa Java, eller se exakt vilken version du har, kan du besöka följande webbplats från programvaruleverantören Oracle:

http://www.java.com/

Klicka på länken “Har jag Java?” och följ instruktionerna för att testa din version av Java.

Jag får ett meddelande om att min webbläsare inte stödjer Java. Vad ska jag göra?

Många moderna webbläsare som Chrome, Edge med flera stödjer inte längre Java1).

Lösningen är att istället använda Internet Explorer om man behöver komma åt ett administrativt system som kräver Java. Internet Explorer stödjer fortfarande Java.

Jag får ett meddelande på en webbsida om att jag måste installera en äldre version av Java, eller omvänt senaste version. Vad ska jag göra?

Kontakta LTH Support och beskriv felmeddelandet och den programvara eller webbplats du önskar använda. Vissa programvaror kräver ibland äldre versioner av Java, medan andra kräver den senaste. Det är därför inte helt enkelt att avgöra vilken version av Java som bör vara installerad och ofta blir det en kompromiss mellan olika krav på Java-versioner från olika administrativa system.

I de senaste versionerna av Java finns dessutom ofta rättningar av allvarliga säkerhetsbrister och andra felrättningar, vilket gör att i allmänhet vill vi att den senaste versionen installeras om det går.

Support

Kontakta LTH Support.

java.txt · Last modified: 2017-10-02 08:13 by robert